View unanswered posts | View active topics It is currently Thu Oct 18, 2018 7:35 am



Reply to topic  [ 21 posts ] 
 Problem applying the 1.0 english patch 
Author Message
Post Problem applying the 1.0 english patch
First of all I'd just like to say thanks for making this!

I'm sorry if I'm posting this in the wrong place, but the english patch sticky seemed purely for things in the patch itself that should be changed (typos, etc.).

What I've done so far: I ran the setup in japanese locale and installed the game itself, no error there. I then ran kami_ap1, then kami_ap2 in japanese locale as well, no errors. Last I ran kami_200 in japanese locale as well, no errors. At this point I can run the .exe just fine and get no errors.

Then I copy the english patch the directory and try to run it. If I run it normally, I get "unable to open archive file". If I run it in japanese locale, I get “invalid start mode: Missing__IRAFN command line switch”.

I use applocale (paploc) to emulate japanese locale. It's worked just fine on the hundreds of other games I've installed.

Again, I'm sorry if this is in the wrong place. It'd be really cool if this is easily fixable and I'm just doing something wrong.

Thanks for reading/helping!


Wed Feb 29, 2012 1:23 pm
Profile
Post Re: Problem applying the 1.0 english patch
Try actually switching to Japanese locale. Applocale is not guaranteed to work.


Wed Feb 29, 2012 1:33 pm
Profile
Post Re: Problem applying the 1.0 english patch
As far as I know japanese locale is just available to the win7 ultimate edition, which I don't have (got home premium).

I did something else which causes the patch to run, though: I ran it from another folder than the game installation one. This runs fine without any errors, which is weird since the readme pretty clearly states that you have to put it in the same folder as the game. Maybe you can use this information for something O.o?

Anyways thanks for answering, at least!


Wed Feb 29, 2012 4:06 pm
Profile
Post Re: Problem applying the 1.0 english patch
You mean you originally installed it in Program Files (or whatever)?

I imagine it wouldn't work in that case if your UAC settings are too high.


Wed Feb 29, 2012 5:26 pm
Profile
Post Re: Problem applying the 1.0 english patch
Nope, I didn't have it installed to C: at all, in fact.


Wed Feb 29, 2012 5:47 pm
Profile
Post Re: Problem applying the 1.0 english patch
I had the exact same problem, here's whats causing the problem, you aren't using JP locale, to fix it all you need to do is change the name of the folder you installed the game on. After that, just run the .exe and you're good to go. Have fun ^^

Oh, I don't think what you name the folder matters btw, I just changed mine to "aaaa" lol.


Wed Feb 29, 2012 9:07 pm
Profile
Post Re: Problem applying the 1.0 english patch
Brokyl wrote:
I had the exact same problem, here's whats causing the problem, you aren't using JP locale, to fix it all you need to do is change the name of the folder you installed the game on. After that, just run the .exe and you're good to go. Have fun ^^

Oh, I don't think what you name the folder matters btw, I just changed mine to "aaaa" lol.


Thanks, but like I said I fixed it by applying the patch from another folder than where it's installed :)

Since I already got a thread going, does anyone know what the "deadbeat" thing that appears in your shop after clearing the deadbeat dungeon is/does?

Edit: read the tips page, I guess it has no disadvantages?


Wed Feb 29, 2012 9:18 pm
Profile
Post Re: Problem applying the 1.0 english patch
Help me I have the problem, When I already install game,patch,english patch,and text fixed patch

but when I entered the game and press new game it will automatically close and always be right this. Help me please


Thu Mar 01, 2012 5:54 am
Profile
Post Re: Problem applying the 1.0 english patch
i have the same problem as godeye

First time i installed the game switching in jap locale. all patch, english patch and the game had no problem. i played till chap 4 like this.

Then i tried to switch localization to my country again to use applocale. But this time the game crashed every time i click on new game or load game. (error message says that ARCGameEngine stop working)

So i unistalled everything and reinstalled all using applocale. So install game-->install 3 patches and then i tried to play. The game run with no problem. Then i applied the english patch (using applocale and placing it in a different directory). and again when i try to play with applocale the game crashes on newgame or load game.


Any advice? i would really prefer to play with applocale. swithing continiusly is boring. TNX


Thu Mar 01, 2012 5:24 pm
Profile

Location: Finland
Post Re: Problem applying the 1.0 english patch
@Clef

Unfortunately not all games work with mere AppLocale, and this seems to be one of them...

As mentioned elsewhere, you could try renaming the folder with plain characters to see if it helps.


Sat Mar 03, 2012 5:53 pm
Profile
Post Re: Problem applying the 1.0 english patch
I've tried again and again but every time I try running the patch it gives an error that it can't patch age.exe. I have all 3 patches installed and am running japanese locale.
I tried reinstalling the entire game and the patches (all 4 uninstall files are present) but I keep getting the same error.

changing the name of the folder to english also doesn't help.

anyone have an idea?
I'm using comodo antivir but I can't find any evidence it's doing anything to these files. (nothing in log, nothing in quarantine)

age.exe itself starts fine but naturally everything is in japanese
I'm using windows 7 64bit and I did NOT install it in the programme folder (in fact, it's not installed on the c: disk).


Tue Mar 06, 2012 11:53 pm
Profile
Post Re: Problem applying the 1.0 english patch
after a lot of fucking around I finally got the problem. it must've been comodo after all. after I completely disabled antivir, defenseplus and sandbox functionality the patcher worked.


Wed Mar 07, 2012 10:58 pm
Profile
Post Re: Problem applying the 1.0 english patch
i don't wanna start another topic so ill just reply here. i installed the english patched but encountered an error when it was about to finish. i tried installing again but it says that i already have the most recent patch. so i tried playing it but the party menu, stats, etc, are left untranslated. what should i do?


Wed Mar 07, 2012 11:01 pm
Profile
Post Re: Problem applying the 1.0 english patch
biribiri_ wrote:
i don't wanna start another topic so ill just reply here. i installed the english patched but encountered an error when it was about to finish. i tried installing again but it says that i already have the most recent patch. so i tried playing it but the party menu, stats, etc, are left untranslated. what should i do?


did you read the instructions? it says you need to install 3 separate extension patches *before* using the translation patch and it sounds like you didn't. make sure the game folder has 4 uninstall files. if they aren't there you didn't do it right.


Thu Mar 08, 2012 2:36 am
Profile
Post Re: Problem applying the 1.0 english patch
vaendryl wrote:
biribiri_ wrote:
i don't wanna start another topic so ill just reply here. i installed the english patched but encountered an error when it was about to finish. i tried installing again but it says that i already have the most recent patch. so i tried playing it but the party menu, stats, etc, are left untranslated. what should i do?


did you read the instructions? it says you need to install 3 separate extension patches *before* using the translation patch and it sounds like you didn't. make sure the game folder has 4 uninstall files. if they aren't there you didn't do it right.

i installed all of the patches before the english patch and the uninstall files are there. is there a way to reinstall the english patch?


Fri Mar 09, 2012 12:18 am
Profile
Post Re: Problem applying the 1.0 english patch
biribiri_ wrote:
vaendryl wrote:
biribiri_ wrote:
i don't wanna start another topic so ill just reply here. i installed the english patched but encountered an error when it was about to finish. i tried installing again but it says that i already have the most recent patch. so i tried playing it but the party menu, stats, etc, are left untranslated. what should i do?


did you read the instructions? it says you need to install 3 separate extension patches *before* using the translation patch and it sounds like you didn't. make sure the game folder has 4 uninstall files. if they aren't there you didn't do it right.

i installed all of the patches before the english patch and the uninstall files are there. is there a way to reinstall the english patch?


I'm not making any promises but you might want to try downloading http://games.seiha.org/patches/Kami_Textfix_1_0.zip and extract the contents of this zip to the contents of your installation directory.

you could also look in the backup folder and get restore the old version of age.exe and try the patch again. this time shut down as much other software as you can. especially protection software such as antivir.


Sat Mar 10, 2012 3:10 am
Profile
Post Re: Problem applying the 1.0 english patch
I've got a problem using the appendix 1.

If i start it i get this http://imageshack.us/photo/my-images/26 ... mapza.png/

I have no antivirus and japanese locale active.

Could that be, because i'm using win 7 64 bit version?


Sat Mar 10, 2012 6:57 am
Profile

Location: Finland
Post Re: Problem applying the 1.0 english patch
Popellord wrote:
I've got a problem using the appendix 1.

If i start it i get this http://imageshack.us/photo/my-images/26 ... mapza.png/

I have no antivirus and japanese locale active.

Could that be, because i'm using win 7 64 bit version?

Shouldn't be, I'm on Win7 64bit, and I'd guess at least a ~quarter of other users here are as well...


Sat Mar 10, 2012 7:27 am
Profile
Post Re: Problem applying the 1.0 english patch
If changing the pc into japanese non-unicode locale AND using no kapanese symbols in path (like D:\games\kamidori) doesn't help, you can just use the UniExtract.
Extract exe>msi, then msi>folder, then move the contents of that folder (the one with the uninstaller inside) into the game folder.
After all that will you install the translation, it works if everything is fine.


Sat Mar 10, 2012 8:08 am
Profile
Post Re: Problem applying the 1.0 english patch
Worked thanks to you.

I had to extract the data out of my temp folder and then i could use Universal extractor.

Thank you very much for your help.

In the meantime I also tried to install it on the laptop of my mother with vista 32 bit. It also didn't work, don't ask me why.


Sat Mar 10, 2012 9:30 am
Profile
Post Re: Problem applying the 1.0 english patch
Xenos Hg wrote:
If changing the pc into japanese non-unicode locale AND using no kapanese symbols in path (like D:\games\kamidori) doesn't help, you can just use the UniExtract.
Extract exe>msi, then msi>folder, then move the contents of that folder (the one with the uninstaller inside) into the game folder.
After all that will you install the translation, it works if everything is fine.


Sorry to necro the crap out of this thread but i've been on the verge of pulling out my hair. I've re-read this thread multiple times and tried everything suggested except for the above solution. Can someone explain more legibly what this guy is saying? I can see to use UniExtract but then i'm lost. I've tried using Japanese Local as Administrator for the installing/english patch. Yet when I run the age.exe I get the ARCgame engine error.


Fri Oct 24, 2014 10:42 pm
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 21 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum

Search for:
Jump to:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group.
Designed by STSoftware for PTF.